CI 묻고 답하기

제목 CI 3.0.5 버전에서의 세션 오류
카테고리 CI 2, 3
글쓴이 쑤닝 작성시각 2024/07/09 11:40:39
댓글 : 2 추천 : 0 스크랩 : 0 조회수 : 329   RSS

안녕하세요. 현재 다른 운영체제에서는 문제가 없는데

Window 7에서 로그인 처리가 되지 않는 현상이 확인 됩니다.............

고객에게 컴퓨터를 바꾸라고 할 수 없는 노릇이라.. 다른 해결책이 있는지 문의 드립니다.

아래는 config 상에 세션 부분만 가져온 내용입니다.

하단의 쿠키 패스는 타 시스템(도메인이 다른) 에서 로그인 시키는 부분때문에 추가되어있습니다. 

$config['sess_driver']           = 'database';
$config['sess_cookie_name']       = 'bmssession';
$config['sess_expiration']           = 86400;
$config['sess_save_path']        = 'bms_sessions';  #DB Table Name
$config['sess_match_ip']         = FALSE;
$config['sess_time_to_update']        = 600;
$config['sess_regenerate_destroy']     = FALSE;
$config['cookie_prefix']    = '';
$config['cookie_domain']   = '';
/*$config['cookie_path']      = '/';*/
$config['cookie_path'] = '/; SameSite=None; Secure';
$config['cookie_secure']   = TRUE;
$config['cookie_httponly']     = FALSE;

스택오버플로우 검색해 봤을때

https://stackoverflow.com/questions/14472869/codeigniter-session-data-lost-after-redirect

중간쯔음에 session_start를 인덱스로 옮기고, security is king 부분을 주석처리 하는 내용이있어

적용시켜봤더니 window 7 에서는 정상적으로 로그인이 되나, 이전에 타 시스템(도메인이 다른)에서 로그인시 문제가 되어

다시 원복해두었습니다 _ _)

혹시 해당 내용에 대한 해결 방법이 있을까요? 

 

 다음글 CI4 Routes 관련 문 (4)
 이전글 setJSON 질문입니다. (1)

댓글

kaido / 2024/07/11 15:05:18 / 추천 0

링크해 주신 스택오버플로우 내용을 읽어보니 

PHP7 이상 설치시에 CI 3.1.1 미만 버전에서 세션 문제가 발생 할수 있다고 나와있네요.

가장 쉬운 해결 방법은 CI 버전을 올리는것 이라고 제시하고 있습니다.

또한 답변 내용중에는 database table 컬럼 길이가 작아서 나오는 문제일 수도 있다고 하니 사이즈도 넉넉히 늘려보시는 것도 방법중 하나일것 같습니다.

쑤닝 / 2024/07/12 15:19:05 / 추천 0

답변 감사합니다. 현재 PHP버전은 5.6 버전이라 다른 운영체제는 문제없는데 window 7에서만 발생합니다..

database 컬럼길이는 조정해서 테스트 해보겠습니다!