CI 묻고 답하기

제목 CI 4.0 composer 설치 관련 문의입니다
카테고리 CI4 관련
글쓴이 php울렁증 작성시각 2020/10/13 14:32:26
댓글 : 9 추천 : 0 스크랩 : 0 조회수 : 208   RSS

Centos7 LEMP 환경에서

코드이그나이터 메뉴얼을 보면서  

코드이그나이터 4.0 설치해보고 있는데 막히는 부분이 있습니다...

 

사용자 계정 홈 디렉토리를 프로젝트 루트 폴더로 잡고 

해당 폴더에 

composer create-project codeigniter4/appstarter

cd appstarter

php spark serve 실행 

=>PHP Warning:  require(/vaseline02/appstarter/app/Config/../../vendor/codeigniter4/framework/system/bootstrap.php): Failed to open stream: No such file or directory in /vaseline02/appstarter/spark on line 44PHP Fatal error:  Uncaught Error: Failed opening required '/vaseline02/appstarter/app/Config/../../vendor/codeigniter4/framework/system/bootstrap.php' (include_path='.:/usr/share/pear:/usr/share/php:/usr/share/pear:/usr/share/php') in /vaseline02/appstarter/spark:44Stack trace:#0 {main}  thrown in /vaseline02/appstarter/spark on line 44

라는 오류가 생깁니다.

중간에 ci 설정을 빼먹은 부분이 있는건가요? 

알기쉽게 상세히 설명 해주시면 감사하겠습니다...

 다음글 CI3 버전 / 검색기능 (2)
 이전글 CI3 버전 사용중인데, 게시판 검색기능을 추가중입니다... (15)

댓글

php울렁증 / 2020/10/13 14:34:57 / 추천 0

appstarter/spark의 44 라인 내용 $app = require rtrim($paths->systemDirectory, '/ ') . '/bootstrap.php';

app/Config/Paths.php 에서 $systemDirectory = __DIR__ . '/../../vendor/codeigniter4/framework/system' 내용은 이러합니다.

아직 시스템 설정을  어떻게 바꿔야할지 몰라서 따로 건드린건 없었습니다.

변종원(웅파) / 2020/10/13 14:41:44 / 추천 0

매뉴얼대로 다 하신거 맞는건가요? 

composer로 설치, 앱 실행(초기 구성 및 설정, 로컬 개발 서버)

변종원(웅파) / 2020/10/13 14:48:00 / 추천 0

재현을 위해 컴포저로 설치후 composer update 하고 설치 디랙토리로 이동하여

php spark serve 했을때 이상없이 실행이 됐습니다.

php울렁증 / 2020/10/13 14:58:43 / 추천 0

@변종원

답변 감사드립니다~

메뉴얼 대로 진행했고 composer update했을때 

Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - fzaninotto/faker v1.9.1 requires php ^5.3.3 || ^7.0 -> your PHP version (8.0.0rc1) does not satisfy that requirement.
    - fzaninotto/faker v1.9.0 requires php ^5.3.3 || ^7.0 -> your PHP version (8.0.0rc1) does not satisfy that requirement.
    - fzaninotto/faker 1.9.x-dev requires php ^5.3.3 || ^7.0 -> your PHP version (8.0.0rc1) does not satisfy that requirement.
    - Installation request for fzaninotto/faker ^1.9@dev -> satisfiable by fzaninotto/faker[1.9.x-dev, v1.9.0, v1.9.1].

이런 메세지가 나왔었는데 php 8.0버전으로 인한 이슈가 있는건가요?

변종원(웅파) / 2020/10/13 15:04:49 / 추천 0
메세지대로 php7버전까지 지원입니다.
php울렁증 / 2020/10/13 15:07:01 / 추천 0

아...메뉴얼 서버 요구사항에 "PHP 버전 7.2 이상이 필요하며" 이렇게 적혀있길래 아무 의심안했었는데 ㅠ

감사합니다 다시 진행 해보겠습니다~

변종원(웅파) / 2020/10/13 15:28:30 / 추천 0

php8은 아직 정식버전도 아닙니다. ^^

ci4는 돌아갈 수도 있으나 기타 연관되어 설치된 라이브러리들이 실행이 안되는 상태입니다.

php울렁증 / 2020/10/13 15:38:09 / 추천 0

네 ㅠㅠ 7.4버전으로 재설치 했습니다 

composer update도 정상적으로 진행됐는데 

vm 환경이라 도메인을 ip주소로 타고 들어가는상황인데

php spark serve 하면  http://localhost:8080으로 접속하라는데 

해당 ip로 접근해서 코드이그나이터 메인페이지를 확인할수는 없을까요?

php울렁증 / 2020/10/13 16:02:13 / 추천 0
해결했습니다!