CI 묻고 답하기

제목 db연결 관련 오류 질문 입니다
카테고리 KI_Board
글쓴이 보라색맛났어 작성시각 2019/12/27 10:55:06
댓글 : 5 추천 : 0 스크랩 : 0 조회수 : 184   RSS

A PHP Error was encountered

Severity : 8192

Message : mysql_escape_string(): This function is deprecated mysql_real_escape_string() instead

 

Filename : mysqli/mysqli_driver.php

 

 

$db['default']['dbdriver'] = 'mysqli';

$db['default']['dbprefix'] = '';

$db['default']['pconnect'] = TRUE;

$db['default']['db_debug'] = FALSE;

$db['default']['cache_on'] = FALSE;

$db['default']['cachedir'] = 'application/cache';

$db['default']['char_set'] = 'utf8';

$db['default']['dbcollat'] = 'utf8_general_ci';

$db['default']['swap_pre'] = '';

$db['default']['autoinit'] = TRUE;

$db['default']['stricton'] = FALSE;

 

 

가끔씩 db가 연결이 끊어지는지 저런 에러메세지가 뜨면서 로그인이 안 되는 경우가 있는데

저러다가 잠시후면 다시 정상으로 돌아옵니다 

어디를 고쳐야 저런 현상이 발생 안 할까요 ..?  위의 경고문 내용의 core 경로에서 mysql을 mysqli로 바꿔주면 될까요..?

 

 다음글 dompdf 사용문의 (4)
 이전글 CodeIgniter HTML Purifier Help...

댓글

한대승(불의회상) / 2019/12/27 11:15:23 / 추천 0

pconnect 만 false로 수정해 주시면 될것 같습니다.

Db의 다른 설정 값은 잘 설정하신것 같네요.

보라색맛났어 / 2019/12/27 11:35:10 / 추천 0
그럼 가끔 디비 연결이 끊기는건 디비 부하가 걸려서 그런걸까요?
변종원(웅파) / 2019/12/27 12:04:33 / 추천 0
현재 php 버전, codeigniter 버전 올려주세요. ci 업데이트가 필요해보입니다.
보라색맛났어 / 2019/12/27 12:52:44 / 추천 0
확인해보니 CI버전은 2.1이고 php는 5.3.3 입니다 제가 인수인계 받은지 며칠도 안 되서 함부로 업데이트 하기가 좀 그렇네요 ;;
변종원(웅파) / 2019/12/27 13:43:45 / 추천 0

보라색맛났어/ ci core를 수정했는지 확인하시고 최소한 ci 2.2.6(2015년 10월 버전)까지는 업데이트 하셔야 합니다. 

https://codeigniter.com/en/download