개발 Q&A

제목 ci2와 php버전 질문드립니다.
카테고리 PHP
글쓴이 손씨가문 작성시각 2022/05/11 11:01:55
댓글 : 2 추천 : 0 스크랩 : 0 조회수 : 523   RSS

안녕하세요.

현재 CI2와 php5버젼을 쓰고있습니다. 

 

php8버젼으로 업그레이드하고, 이후 신규소스는 CI4 버젼을 쓰고 CI2 쓰던것은 그대로 CI2를 이용하려고 하는데,

 

혹시 php8버젼으로 업그레이드 시에 CI2는 더 이상 쓸수 없게되는지 궁금합니다.

현재 가져다 써보니 밑에 에러가 뜨는데, 값을 못불러오네요.

Undefined array key "subclass_prefix"

 

 

 다음글 페키지 구조 이게 가능한지 조언부탁드립니다. . . (8)
 이전글 모바일 웹에서 세션 (2)

댓글

한대승(불의회상) / 2022/05/11 14:02:50 / 추천 1

오류 확인하면서 프레임워크를 수정해야 하는데 ci2는 php5에서 동작시키는게 맞는것 같습니다.

사실상 PHP7 이상 버전은 지원하지 않는다고 보는게 맞습니다.

손씨가문 / 2022/05/11 15:52:20 / 추천 0

답변 감사드립니다. 

CI2를 그대로 두고 CI4 버젼을 천천히 다시 만들어야겠네요.