개발 Q&A

제목 CI 및 php 버전 질문...
카테고리 기타
글쓴이 박뚱글 작성시각 2019/04/03 21:28:19
댓글 : 2 추천 : 0 스크랩 : 0 조회수 : 161   RSS

CI를 설치하고나서 

 

실행했습니다..

 

하지만 에러가 나버려서 구글링해도 안나와서 조언을 구하고자 질문합니다.

 

Message: __autoload() is deprecated, use spl_autoload_register() instead

Filename: config/config.php

Line Number: 3

 

아파치는 2.4 이고.. php 는 7.3 버전인데 php 버전이높아서 이런 문제가 발생하나요?;

 다음글 혹시 iwinv 서비스 사용하고 계신분.. 방화벽 설정... (3)
 이전글 aws 인프라 관련 조언 (5)

댓글

변종원(웅파) / 2019/04/03 22:00:22 / 추천 1

ci 3점대는 php7.2에서 안돌아갈겁니다.

매뉴얼의 change log 보시면 버전정보 찾아보실 수 있습니다.

kaido / 2019/04/04 09:34:34 / 추천 0

CI 3.1.10  최신 버전으로 올려보세요.  php 7.3 까지 디버그 패치 하고있는걸 보아, 작동 할거로 보여집니다.

다만 에러의 라인수를 보았을때 순정(?) 상태가 아닌것 같습니다.

CI 문제가 아니라 사용자의 함수 사용 미스가 아닐지 조심스레 예상해봅니다.