질문 Q #12458
routes.php 설정 질문
인생초보 2015-08-24 14:53:31
일단 ver 2.2.3 입니다.

아래와 같이 설정하여서 테스트 중입니다만.
local 에서는 문제없이 잘 돌아갑니다.
문제는 centos 서버에 올리면 default 말고는 
The requested URL /Consumer was not found on this server.
위의 오류가 발생합니다.

어디부분을 살펴봐야할지 잘 모르겠습니다.
어디부분을 살펴봐야할까요. 
.htaccess 파일도 올렸습니다.
감을 못잡겠네요. 어떤 문제인지.

$route['default_controller'] = "oauth2/Oauth2/index";
$route['404_override'] = '';


//외부서비스 
$route['consumer'] = "oauth2/Consumer/index";
$route['consumer/(:any)'] = "oauth2/Consumer/$1";

//유저
$route['oauth2/client'] = "oauth2/client/index";
$route['oauth2/client/(:any)'] = "oauth2/client/$1";
답변 4
#1 변종원(웅파) 2015-08-24 17:31:00
리눅스는 대소문자 구분합니다.
#2 인생초보 2015-08-24 17:55:21
웅파님 controllers 의 consumer.php 는 소문자이고 클래스는 Consumer 입니다.
라우터 에는 아래와 같이 되어있습니다. 
$route['consumer'] = "oauth2/consumer/index";

이부분이 문제가 되는걸까요. 

일단 변경해가며 테스트중이긴한데. 해결이 안되고 있네요.
#3 인생초보 2015-08-24 18:25:36
apache 로그를 확인해보니 파일경로를 아래와 같이 찾고있네요.
[Sun Aug 23 04:37:26 2015] [error] [client 211.xxx.xxx.xxx] File does not exist: /var/www/html/OAuth2.0/consumer

routes.php 에서 <span neue,helvetica,arial,sans-serif"="">$route['consumer'] = "oauth2/consumer/index"; 이렇게 설정을 하였는데도 .위와 같이 되는 이유가 뭘까요..ㅠㅠ
#4 인생초보 2015-08-24 19:11:09
자답입니다. ㅠㅠ
httpd.conf 에 AllowOverride 설정을 변경하지 않은 문제였네요.

옛날에도 이걸로 헤딩한번 한적있었는데. 머리가 돌이 됐나. 또 까먹고 헤메고 있었네요 ㅜㅜ